Skip to content

Gacutil exits without error, does nothing

July 4, 2011

Problem:
You need to add an assembly to the GAC on a server computer. To make it simple, copy the gacutil.exe (and the gacutil.exe.config) to the server and execute it as usual. But it prints only two lines of copyright notice and exits without adding the assembly to the GAC or giving any error:

C:\>gacutil -i myassembly.dll
Microsoft (R) .NET Global Assembly Cache Utility.  Version 4.0.30319.1
Copyright (c) Microsoft Corporation.  All rights reserved.

C:\>_

Solution:
The problem is that gacutil.exe requires the gacutlrc.dll to run. In the .NET SDK this dll is in the 1033 folder, just below the folder of the gacutil.exe (C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin\NETFX 4.0 Tools\1033).

When copying the gacutil to the server, make sure that you copy all 3 required files: gacutil.exe, gacutil.exe.config and gacutlrc.dll. You can put them side-by-side in a same folder but you need them all.

Advertisements
6 Comments
  1. Shamsuddin permalink

    Thank you, this helped us too

  2. Eli Bent permalink

    Thank you for this! You (and Google) are my very good friends indeed.

  3. Mushtaque permalink

    Thanks a million.

    Best Regards,
    Mushi

  4. Tin permalink

    good find!
    Thanks.

  5. ZenGeek permalink

    Thanks a lot too.. This helped me 🙂

  6. Krysis permalink

    This definitely helped! Thanks a lot!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: