Skip to content

Configuration Wizard error: The password supplied with the username domain\username was not correct. Verify that it was entered correctly and try again.

December 2, 2011

If you are running the SharePoint 2010 Products Configuration Wizard you may get the following error:

The password supplied with the username domain\username was not correct. Verify that it was entered correctly and try again.

This error occurs when you are reinstalling SharePoint on a computer where there had been a SharePoint installation earlier and the SharePoint Central Administration v4 website and application pool still exists in IIS.

To resolve the problem, open IIS and delete both the SharePoint Central Administration v4 website and application pool. Then the Configuration Wizard should run without problem.

The full error message from the logfile:

System.ComponentModel.Win32Exception: The password supplied with the username domain\username was not correct. Verify that it was entered correctly and try again.
at Microsoft.SharePoint.Administration.SPFarm.ValidateLogonAccount(String& username, SecureString password)
at Microsoft.SharePoint.Administration.SPManagedAccount.SetPassword(SecureString value)
at Microsoft.SharePoint.Administration.SPProcessIdentity.SetPassword(SecureString value)
at Microsoft.SharePoint.Administration.SPApplicationPool..ctor(String name, SPWebService service)
at Microsoft.SharePoint.Administration.SPWebApplication.CreateDefaultInstance(SPWebService service, Guid id, String applicationPoolId, SPProcessAccount processAccount, String iisServerComment, Boolean secureSocketsLayer, String iisHostHeader, Int32 iisPort, Boolean iisAllowAnonymous, DirectoryInfo iisRootDirectory, Uri defaultZoneUri, Boolean iisEnsureNTLM, Boolean createDatabase, String databaseServer, String databaseName, String databaseUsername, String databasePassword, SPSearchServiceInstance searchServiceInstance, Boolean autoActivateFeatures)
at Microsoft.SharePoint.Administration.SPWebApplication.CreateDefaultInstance(SPWebService service, Guid id, String applicationPoolId, IdentityType identityType, String applicationPoolUsername, SecureString applicationPoolPassword, String iisServerComment, Boolean secureSocketsLayer, String iisHostHeader, Int32 iisPort, Boolean iisAllowAnonymous, DirectoryInfo iisRootDirectory, Uri defaultZoneUri, Boolean iisEnsureNTLM, Boolean createDatabase, String databaseServer, String databaseName, String databaseUsername, String databasePassword, SPSearchServiceInstance searchServiceInstance, Boolean autoActivateFeatures)
at Microsoft.SharePoint.Administration.SPAdministrationWebApplication.CreateDefaultInstance(SqlConnectionStringBuilder administrationContentDatabase, SPWebService adminService, IdentityType identityType, String farmUser, SecureString farmPassword)
at Microsoft.SharePoint.Administration.SPFarm.CreateAdministrationWebService(SqlConnectionStringBuilder administrationContentDatabase, IdentityType identityType, String farmUser, SecureString farmPassword)
at Microsoft.SharePoint.Administration.SPFarm.CreateBasicServices(SqlConnectionStringBuilder administrationContentDatabase, IdentityType identityType, String farmUser, SecureString farmPassword)
at Microsoft.SharePoint.Administration.SPFarm.Create(SqlConnectionStringBuilder configurationDatabase, SqlConnectionStringBuilder administrationContentDatabase, IdentityType identityType, String farmUser, SecureString farmPassword, SecureString masterPassphrase)
at Microsoft.SharePoint.Administration.SPFarm.Create(SqlConnectionStringBuilder configurationDatabase, SqlConnectionStringBuilder administrationContentDatabase, String farmUser, SecureString farmPassword, SecureString masterPassphrase)
at Microsoft.SharePoint.PostSetupConfiguration.ConfigurationDatabaseTask.CreateOrConnectConfigDb()
at Microsoft.SharePoint.PostSetupConfiguration.ConfigurationDatabaseTask.Run()
at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

Advertisements
5 Comments
  1. toy permalink

    Thanks very very much, works for me

  2. Ronak permalink

    reset iis and close and re-open powershell and ensure that the password is correct before you run the script

  3. Chris permalink

    Thanks, I deleted the iis sites but forgot the pesky application pools, bang my head for hours.

  4. Thanks a lot. It worked for me.

  5. Thor permalink

    I’m facing the same issue. I tried removing them what you said. After that also I am facing the issue.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: